RIP, EIGRP, OSPF, IS-IS, BGP, MPLS, VTP, STP.
alienkidmj12
New Member
Posts:
33
Joined:
Mon Apr 22, 2013 1:32 pm
Certs:
mcp

cisco877w wireless help

Wed May 01, 2013 1:58 pm

im unable to get the wireless clients to use the 192.168.0.1 gateway for internet traffic, wireless clients connect okay but no web :(

midnight-cisco877w#sh running-config
Building configuration...

Current configuration : 3813 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname midnight-cisco877w
!
boot-start-marker
boot-end-marker
!
enable secret 5 ????????
enable password ????????
!
no aaa new-model
clock timezone GMT 0
!
dot11 ssid midnight-cisco-emma
vlan 3
max-associations 4
authentication open
authentication key-management wpa
mbssid guest-mode
wpa-psk ascii 0 ???????????
!
dot11 ssid midnight-cisco-sives
vlan 2
max-associations 4
authentication open
authentication key-management wpa
mbssid guest-mode
wpa-psk ascii 0 ??????????
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.50 192.168.0.99
ip dhcp excluded-address 192.168.0.1 192.168.0.41
!
ip dhcp pool Wireless-DHCP-Pool-vlan2
network 10.10.1.0 255.255.255.0
default-router 192.168.0.1
dns-server 192.168.0.1
lease 3
!
ip dhcp pool Wireless-DHCP-Pool-vlan3
network 10.10.2.0 255.255.255.0
default-router 192.168.0.1
dns-server 192.168.0.1
lease 3
!
ip dhcp pool Wired-DHCP-Pool-vlan1
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 192.168.0.1
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
bridge irb
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
duplex full
speed 100
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface Dot11Radio0
no ip address
ip nat inside
ip virtual-reassembly
no dot11 extension aironet
!
encryption vlan 2 mode ciphers aes-ccm tkip
!
encryption vlan 3 mode ciphers aes-ccm tkip
!
ssid midnight-cisco-emma
!
ssid midnight-cisco-sives
!
mbssid
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel least-congested 2412 2442 2462
station-role root
no cdp enable
!
interface Dot11Radio0.2
description Wireless-LAN-vlan2
encapsulation dot1Q 2
ip nat inside
ip virtual-reassembly
no cdp enable
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!
interface Dot11Radio0.3
description Wireless-LAN-vlan3
encapsulation dot1Q 3 native
ip nat inside
ip virtual-reassembly
no cdp enable
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
!
interface Vlan1
description Wired-LAN
ip address 192.168.0.41 255.255.255.0
!
interface Vlan2
description Wireless-LAN
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 2
bridge-group 2 spanning-disabled
!
interface Vlan3
description Wireless-LAN
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 3
bridge-group 3 spanning-disabled
!
interface BVI2
description Wireless Bridge VLAN2
ip address 10.10.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI3
description Wireless Bridge VLAN3
ip address 10.10.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip default-gateway 192.168.0.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
bridge 2 protocol ieee
bridge 2 route ip
bridge 3 protocol ieee
bridge 3 route ip
banner motd ^C
******************************************
* Unauthorized access prohibited
*
* You are connected to CISCO 877W Router
* at ip 192.168.0.41.
*
******************************************
^C
!
line con 0
no modem enable
line aux 0
line vty 0 4
password easther3
login
!
scheduler max-task-time 5000
ntp server 194.35.252.7
end

midnight-cisco877w#

User avatar
ristau5741
Post Whore
Posts:
10618
Joined:
Tue Aug 21, 2007 2:15 pm
Certs:
Instanity

Re: cisco877w wireless help

Wed May 01, 2013 2:01 pm

Code: Select all
ip dhcp pool Wireless-DHCP-Pool-vlan2
network 10.10.1.0 255.255.255.0
default-router 192.168.0.1
dns-server 192.168.0.1
lease 3
!
ip dhcp pool Wireless-DHCP-Pool-vlan3
network 10.10.2.0 255.255.255.0
default-router 192.168.0.1
dns-server 192.168.0.1
lease 3


is this correct, you plan to hand out 10.10.1.0/24 ip addresses with a gateway of 192.168.0.1 ?
you plan to hand out 10.10.2.0/24 ip addresses with a gateway of 192.168.0.1

that don't fly.
Tips of the day:
- The human mind is the ultimate creation invention.
- I have so many customers, my customers have customers.
- Sausage time
- POP, stack, and store

alienkidmj12
New Member
Posts:
33
Joined:
Mon Apr 22, 2013 1:32 pm
Certs:
mcp

Re: cisco877w wireless help

Wed May 01, 2013 2:02 pm

hmmm i thought it might not :) i tried changing the subnet mask to no avail :) anyway around it ?

User avatar
ristau5741
Post Whore
Posts:
10618
Joined:
Tue Aug 21, 2007 2:15 pm
Certs:
Instanity

Re: cisco877w wireless help

Wed May 01, 2013 2:05 pm

yer default gateways need to be on the same subnet as the IP addresses you are doling out.
that way they can reach the default gateway, as it would be on the same network.
you should have an IP assigned to the wireless network?
Tips of the day:
- The human mind is the ultimate creation invention.
- I have so many customers, my customers have customers.
- Sausage time
- POP, stack, and store

alienkidmj12
New Member
Posts:
33
Joined:
Mon Apr 22, 2013 1:32 pm
Certs:
mcp

Re: cisco877w wireless help

Wed May 01, 2013 2:12 pm

yeah wireless clients connect, but no routing, thanks for your help, gona give it a shot.

User avatar
ristau5741
Post Whore
Posts:
10618
Joined:
Tue Aug 21, 2007 2:15 pm
Certs:
Instanity

Re: cisco877w wireless help

Wed May 01, 2013 2:14 pm

do the clients get ip addresses?
Tips of the day:
- The human mind is the ultimate creation invention.
- I have so many customers, my customers have customers.
- Sausage time
- POP, stack, and store

alienkidmj12
New Member
Posts:
33
Joined:
Mon Apr 22, 2013 1:32 pm
Certs:
mcp

Re: cisco877w wireless help

Wed May 01, 2013 2:52 pm

ok ive set up the wireless stuff on vlan 1, but unable to create bvi now :(

midnight-cisco877w(config-if)#description WiredWireless Bridge VLAN1
midnight-cisco877w(config-if)#ip address 192.168.0.1 255.255.255.0
% 192.168.0.0 overlaps with Vlan1
midnight-cisco877w(config-if)#exit

.
.
.
.
what am i doing wrong,,,,,config follows.
.


midnight-cisco877w#sh running-config
Building configuration...

Current configuration : 4524 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname midnight-cisco877w
!
boot-start-marker
boot-end-marker
!
enable secret 5 ....................
enable password ...................
!
no aaa new-model
clock timezone GMT 0
!
dot11 ssid midnight-cisco-emma
vlan 3
max-associations 4
authentication open
authentication key-management wpa
mbssid guest-mode
wpa-psk ascii 0 ...................
!
dot11 ssid midnight-cisco-sives
vlan 2
max-associations 4
authentication open
authentication key-management wpa
mbssid guest-mode
wpa-psk ascii 0 ...................
!
dot11 ssid midnight-cisco-squirrel
vlan 1
max-associations 4
authentication open
authentication key-management wpa
mbssid guest-mode
wpa-psk ascii 0 ...................
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.50 192.168.0.99
ip dhcp excluded-address 192.168.0.1 192.168.0.41
!
ip dhcp pool Wireless-DHCP-Pool-vlan2
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 192.168.2.1
lease 3
!
ip dhcp pool Wireless-DHCP-Pool-vlan3
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
dns-server 192.168.3.1
lease 3
!
ip dhcp pool WiredWireless-DHCP-Pool-vlan1
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 192.168.0.1
lease 3
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
bridge irb
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
duplex full
speed 100
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface Dot11Radio0
no ip address
ip nat inside
ip virtual-reassembly
no dot11 extension aironet
!
encryption vlan 2 mode ciphers aes-ccm tkip
!
encryption vlan 3 mode ciphers aes-ccm tkip
!
encryption vlan 1 mode ciphers aes-ccm tkip
!
ssid midnight-cisco-emma
!
ssid midnight-cisco-sives
!
ssid midnight-cisco-squirrel
!
mbssid
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
channel least-congested 2412 2442 2462
station-role root
no cdp enable
!
interface Dot11Radio0.1
description WiredWireless-LAN-vlan1
encapsulation dot1Q 1
ip nat inside
ip virtual-reassembly
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.2
description Wireless-LAN-vlan2
encapsulation dot1Q 2
ip nat inside
ip virtual-reassembly
no cdp enable
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!
interface Dot11Radio0.3
description Wireless-LAN-vlan3
encapsulation dot1Q 3 native
ip nat inside
ip virtual-reassembly
no cdp enable
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 spanning-disabled
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
!
interface Vlan1
description WiredWireless-LAN
ip address 192.168.0.41 255.255.255.0
!
interface Vlan2
description Wireless-LAN
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 2
bridge-group 2 spanning-disabled
!
interface Vlan3
description Wireless-LAN
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 3
bridge-group 3 spanning-disabled
!
interface BVI2
description Wireless Bridge VLAN2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI3
description Wireless Bridge VLAN3
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface BVI1
description WiredWireless Bridge VLAN1
no ip address
!
ip default-gateway 192.168.0.1
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
bridge 2 protocol ieee
bridge 2 route ip
bridge 3 protocol ieee
bridge 3 route ip
banner motd ^C
******************************************
* Unauthorized access prohibited
*
* You are connected to CISCO 877W Router
* at ip 192.168.0.41.
*
******************************************
^C
!
line con 0
no modem enable
line aux 0
line vty 0 4
password easther3
login
!
scheduler max-task-time 5000
ntp server 194.35.252.7
end

midnight-cisco877w#

alienkidmj12
New Member
Posts:
33
Joined:
Mon Apr 22, 2013 1:32 pm
Certs:
mcp

Re: cisco877w wireless help

Wed May 01, 2013 2:54 pm

ristau5741 wrote:do the clients get ip addresses?


clients were getting ip addresses yes, either 192.168.2.x or 192.168.3.x


Return to Cisco Routing and Switching

Who is online

Users browsing this forum: Exabot [Bot] and 113 guests