Dynamips/GNS3, .net files, and Cisco networking labs.
chiragrao
New Member
Posts:
1
Joined:
Wed Nov 04, 2015 11:35 pm
Certs:
CCNP Security

GSN3 basic NAT not working

Wed Nov 04, 2015 11:50 pm

Hi Guys,

I am trying to simulate a simple NAT overload lab, but it is not working. The same works in Cisco Packet Tracer as well as physical lab.

VPCS PC1 192.168.1.2/24 --> R1 fa0/0 192.168.1.1/24 --> R1 fa0/1 65.1.1.1/30 --> R2 fa0/0 65.1.1.2/30

L2 basic switches are connecting VPCS and R1, as well as R1 and R2.

VPCS PC1 points to 192.168.1.1 as a default gateway.
R1 has a default static route pointing to 65.1.1.2(R2).

Basic connectivity works (pinging to/fro from devices).

Here is the config on R1:

interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside

interface FastEthernet1/0
ip address 65.1.1.1 255.255.255.252
ip nat outside

ip route 0.0.0.0 0.0.0.0 65.1.1.2

ip nat inside source list 1 interface FastEthernet1/0 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255 log

Problem: R1 is unable to NAT traffic. It sends traffic without NATTing. I can see it in Wireshark. Since R2 does not know about 192.168.1.0 network, it drops the traffic. Ping is sourced from the VPCS PC1 192.168.1.2.

The access-list 1 192.168.1.0 does not get any hits.

If I change the access-list to 'access-list 1 permit any', everything starts working fine.

I would appreciate if anyone could share the reason behind this.

Regards,

Chirag
Attachments
GAN3 NAT.jpeg.jpg
GAN3 NAT.jpeg.jpg (15.07 KiB) Viewed 4816 times

edgenet
New Member
Posts:
36
Joined:
Thu Mar 15, 2012 6:58 pm
Certs:
CCNP

Re: GSN3 basic NAT not working

Wed Jan 20, 2016 5:24 am

I thought it was just me doing the wrong thing. Have you got any solutions yet?

ski
Senior Member
Posts:
303
Joined:
Sat Mar 31, 2012 5:01 pm
Certs:
CCNA CCNP CCIP CCNA Security

Re: GSN3 basic NAT not working

Tue Jan 26, 2016 2:41 pm

Delete the 'log' from your ACL.


Return to Dynamips/GNS3 and Labs

Who is online

Users browsing this forum: No registered users and 10 guests